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    Plesk common problems

    Plesk offers a lot of useful options for managing your VPS. However, it might happen that a mistake in your configuration creates a problem. In this article we look at some of the common questions we receive and at the frequently used solutions.


    The Plesk repair tool

    Most problems in Plesk can easily be solved with the Plesk Repair tool which automatically checks and fixes almost all aspects of Plesk. Connect via commandline or the VPS console and use the following command:

    sudo plesk repair all -y -v

    Nginx / Apache doesn’t start automatically

    This problem can occur with VPSs using Plesk that have been installed before April 2018. We have implemented the following solution in our Plesk image so installations from April 2018 will no longer experience this problem.

    Symptom:

    Nginx / Apache does not start after restarting a VPS. This is usually noticed after performing an automatic update and then restarting the VPS.

    Cause:

    We have examined this problem in detail and consulted with Plesk. The problem is related to DAD as far as we can determine (see this link for an explanation about DAD). Your OS (in this case CentOS 7) does not have an ‘is an ipv6 address assigned’ service in systemd. What happens is that your network service starts, then Nginx / Apache starts, but your IPv6 address is not actually ready for use, so Nginx / Apache cannot connect to it and the service crashes (you will see an error message in journalctl -xe).

    Solution:

    Step 1

    Create the following configuration file:

    sudo nano /usr/lib/sysctl.d/60-transip.conf

     

    Step 2

    Add the following line to turn off DAD and save the file (ctrl + x> y> enter)

    net.ipv6.conf.eth0.accept_dad = 0

     

    Step 3

    Open the nginx / apache configuration file (replace nginx.service with httpd.service if you use Apache):

    sudo nano /usr/lib/systemd/system/nginx.service

     

    Step 4

    At the beginning of the file, adjust the section behind 'After' so the line looks like this:

    After=network-online.target

    After a restart of your VPS the problem should no longer occur.


    Error: The license key is invalid

    When you restore a backup or when you restore a snapshot of a VPS which uses a license, it is possible you will receive a warning the license is invalid or has expired. This is always the case when you restore a snapshot on a different VPS, because that server will have a different IP address as the original VPS.

    You can solve this problem through SSH, or the VPS-console using one of the following solutions:

    /usr/local/psa/bin/sw-engine-pleskrun /usr/local/psa/admin/plib/DailyMaintainance/script.php -f UpdateKeys
    

    or:

    plesk repair all -y -v
    

    Underscore in DNS-records (DKIM, SRV)

    If you manage the DNS of your domain in Plesk and you want to add a DNS record with an underscore _ in the name you get an error message. This is the result of a bug in Plesk and can be solved by using the following command via commandline or the VPS console:

    plesk bin dns --add jedomein.nl -cname transip-A._domainkey -canonical _dkim-A.transip.email
    • Replace ‘yourdomain.com’ by your actual domain name.
    • Replace 'transip-A._domainkey' by the name of the subdomain you want to add.
    • Replace '_dkim-A.transip.email' by the value of the record you want to add.   

    The Plesk DNSSEC extension doesn’t work 

    Problems with the Plesk DNSSEC extension are usually caused by a mistake in the license key file on your VPS. You solve this by retrieving the license key file again as follows: 

     

    Step 1

    Log in to Plesk and go to 'Tools & Settings'> 'License Management'.

    plesk tools and settings license management


     

    Step 2

    Click on 'Retrieve Keys'. You can now use the DNSSEC extension from 'Extension Settings'> 'Plesk DNSSEC'.

    plesk retrieve license key


     

    Above we have covered some problems that we get asked from time to time. Should you have any questions left regarding this article, do not hesitate to contact our support department. You can reach them via the ‘Contact Us’ button at the bottom of this page.

     

     

     

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